Search

Loading...
Join this Blog for direct reference of any post into your inbox. To join just click on "Join this Site" under "Follower" then Login with your Email.*** DECLARATION: I Maintain this Blog for Helping Myself While at Work and Welcome any body Needing Help!!!.*** CAUTION: Using any of the script from this Blog may contain at Own Risk. These scripts May or May not have been Tested.***

Monday, 21 May 2012

Install Oracle Developer Suite 10g on Windows 7 (64bit)

Recently, I have install Oracle Developer Suite on Windows 7(64bit) on my laptop while installing developer suite i found the error. Once i read the step nice and clean work done by Duh-Microsfot did it again blog and try the same and achieve the "succeful installation".
Oracle 10g Developer suite:
Steps:
- Extract the setup downloaded from OTN.
- Right click on the setup.exe property, set compatibility to Windows XP SP2
- Edit the virtual memory size to custom size from 1024m to 4000m, restart it
- Now Run the setup.exe
Increase Virtual Memory: Depending upon actual memory available with your computer, setup virtual memory. You can go upto double the size of actual memory while setting up your virtual memory.


















After setting the virtual memory restart the system....
Now open the disk1 folder of the developer suite and locate "setup.exe"










Right click on "Setup.exe" and change the comparability to windows XP service pack 2 or 3.

Now run the setup, if you already have Sp1 installed and running latest Java runtime, you may come across PSAPI.DLL errors a number of times, caused by a function call missing information. You can safely ignore the warning messages and complete the installation.























Install Oracle 10g Database:
Go to Your installer disk folder Example: "E:\Installers\Oracle_10g_1023\Disk1\stage\prereq\db"
locate the file “refhost.xml”, open it with notepad and add and edit the following:
<!–Microsoft Windows 7–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.1″/>
</OPERATING_SYSTEM>
Finally it look like this
<CERTIFIED_SYSTEMS>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.0″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.1″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.2″/>
</OPERATING_SYSTEM>
<!–Microsoft Windows Vista–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.0″/>
</OPERATING_SYSTEM>
<!–Microsoft Windows 7–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.1″/>
</OPERATING_SYSTEM>
</CERTIFIED_SYSTEMS>
Now run the Oracle installer and you would see the installation completes without giving any errors.

73 comments:

  1. Hi Trying to repeat but keep getting error around no compatible version. Only supported are 5.0, 5.1 or 5.2 . Reports my acutal version is 6.1. Is there a patch Im missing

    ReplyDelete
    Replies
    1. go to the “install/oraparam.ini” file and change the certified version comma-delimited list there and then try again. Donot forget whie running installar right click the setup.exe->properties->compatibility tab->Select Windows XP Service pack 2.

      Delete
  2. worked great! thanks

    ReplyDelete
  3. Getting error "Abnormal program termination. An internal error has occurred".

    ReplyDelete
  4. Hi,

    I am trying to instal reps developer 10g on windows 7 64-bit. I was actaully able install it successfully the first time. Later as I uninstalled it. Now if I am re installing it , it paases the poing of select home folder and when I click for 'Complete' insatllation its begins but keeps thowing error : Stop installation of this component only - failed to create service for library.

    Did anyone face this . Any help is greatly appreciated

    ReplyDelete
    Replies
    1. Go to services (run services.msc) and check the "security center service" and all its dependencies services is automatic. try to restart these service (stop then start). While installing temporarily disable security software (if any). Hope you will find the solution. I request you guys if you need quick response please comment with your specified identification.

      Delete
  5. I installed it. It did worked. However after opening several times it would not fully open. Meaning the splash opens. I get to select the type of report. Wizard, build, open exist but after selecting that the icon displays in the system tray but the application does not open. Did I miss anything. Howard

    ReplyDelete
  6. Hi Sir,

    I am doing Oracle 9i developer suite application. I want to make a silent installation with rsp file. Source is installing fine without any error using autorun.exe. The Autorun.exe file is calling setup.exe internally and installing the application. I able to install the application in silent mode using setup.exe with rsp file. But i am getting an error as "Procedure entry point GetProcessImageFileNameW could not be located in the dynamic link library PSAPI.DLL" during installation.
    I am unable to resolve this issue. The PSAPI.DLL file is available in the system32 folder which is higher version. Application also extrating the same DLL file in the temp folder which is lower version. After Installation also there is no entry of the PSAPI.DLL file on the machine.

    Please provide the solution to resolve it if you have experienced to resolve this kind of issues.

    Thanks in Advance.

    ReplyDelete
    Replies
    1. On which OS version you are trying to install Oracle 9i Developer suite

      Delete
  7. Windows 7 x32 bit platform and version is 6.1.7601

    ReplyDelete
    Replies
    1. Is there any special reason to install oracle 9i developer on windows 7 X 32 bit
      I am not sure about developer Suite 9i support for use on Windows 7. Ask and confirm
      with expert about this.

      Delete
  8. Yes sir. I want to install it silently with rsp file. Appiication is installing fine with autorun.exe file without giving any error. But that specified DLL error is coming when i am trying to install it using setup.exe.

    ReplyDelete
  9. hi ,

    i am using oracle 10g , developer suite 9i . its working fine in windows xp system. i have a problem in windows 7 32 bit system. i changed the jvm.dll file and after changing i could get the form seen, but am not able to type anything. suppose i type 1 in login screen (username) , it appears after some scrolling of mouse repeatedly. it looks like some thing is blocking in ie . i use IE 9. how do i resolve this issue.

    thanks in advance

    ReplyDelete
    Replies
    1. Sorry,
      I never installed oracle 9i developer suite on oracle 10g.
      You can try on XP or Windows 2003

      Delete
  10. Hello,

    I'm trying run the Forms application in windows 7 64 bits. I did the installation doing this steps: change the mem. virtual, solve the compatibility with xp sp3 in the setup, installing patch witch Opatch and update the developer suite version, etc.

    It never worked. When I open a form, the program crash. I tried several things to run the application in vain. I hope that you can help me.

    Excuse for my english, I'm spanish. Thanks and greetings.

    ReplyDelete
    Replies
    1. If you do not have any virtual memory isse
      then just right click on setup.exe
      then click properties: (from the tab select compatibility and select windows xp service pac3/pac2 from compatibility mode settings)
      Click ok
      And now try to install.

      Delete
  11. Shahid,

    Thanks a lot for systematic post. It helped me a lot. It will be good if you can provide navigation to change virtual memory setting too.

    Here is quick navigation if someone is interested.
    Click on Windows start button (left hand bottom) > right click on Computer > Properties > Advance System Settings (left panel) > Select Advance Tab > Under Performance area click on Settings... > Go to Advance Tab > In Virtual Memory select Change... button

    You will see screen for changing virtual memory given above.

    Thanks again,
    Vijay

    ReplyDelete
  12. Dear shahid
    Assalamualaikum

    I would like request you to please help to solve this errors I using Oracle 10g/developer 10g on windows -7

    I have installed windows-7 ultimate verson
    change vertual memory 1000 to 4000 before installation and compatibility service pack -2

    installed oracle 10g/developer suite 10g before installation compatibility service pack -2

    everything working fine but one problems


    Problems------ any old form.fmb which is designed in same oracle10g version oracle developer suite 10g in windows xp need to open in windows -7 developer suite 10g errors appearing
    and unable to open

    errors
    oracle form designer has stoped working check online solution /close program


    please guide and and reply me in my email to solve this issues.


    your help will be highly appreciated

    Thanks & Best regards

    M Z Islam

    mailto : Zafrul_islam@yahoo.com

    ReplyDelete
    Replies
    1. Dear,

      is your forms created on Windows 7 itself is working?
      If YES
      then check your browser either clean install "Netscape or IE7.
      If NO
      then check your Jinitiator 9.0.0.6 Version in windows7.
      For your convenient check the below link: How to Install

      Delete
  13. salam sir g we install oracle 10g installation cmpletely perfect but when we run oracle forms so its will be hanging.

    ReplyDelete
    Replies
    1. salam sir g we install oracle 10g installation cmpletely perfect in window7 64bit original window but when we run oracle forms so its will be hanging.

      Delete
    2. Which version of Jinitiator you are using. If it is oracle 10g (10.1.2.3). Try to upgrade it JRE 1.6p20.
      For more information related problem check the link of discussion: https://cn.forums.oracle.com/forums/thread.jspa?messageID=9140685

      Delete
  14. Oracle Developer Suite 10g (10.1.2.0.2)VERSION after installation form run but when we click on form so its hange and slow

    ReplyDelete
    Replies
    1. This is due to the jinitiator version. Try to install suitable JRE. Check the above discussion for more details.

      Delete
  15. when iam installing oracle 10g in win7 proffisional this error occure "checking operating system version:must be 4.0,5.0,5.1 or 5.2. actual 6.1 existing oracle universal installer,"

    ReplyDelete
    Replies
    1. You have changed the version value in refhost.xml file?. Try to follow the overall instruction.

      Delete
  16. sir,
    i am trying to install oracle 10g developer suite on win7 home premium. i have made all the changes mentioned above yet when i run the setup.exe, it passes all the parameters and installer crashes with error... "SETUP.EXE HAS STOPPED WORKING". please help me in installing the oracle developer suite 10g.

    database installed on my machine is 11gR2. Does this error is due to difference in version of Database and developer suite.
    Java Environment is JRE 7.

    Please help..

    ReplyDelete
    Replies
    1. Are you able to install it now? Can you share how you do it?

      Delete
  17. I am not sure but i think you are right as you have > version 11g database already installed. It can be a reason. Try to installed with 10g database.

    ReplyDelete
  18. What is the below error? pls help
    OiilNativeException is thrown
    OiilNativeException is thrown
    OiilNativeException is thrown
    OiilNativeException is thrown
    OiilNativeException is thrown

    path: C:\Users\lb\AppData\Local\Temp\OraInstall2013-04-14_06-53-42PM\jre\1.4.2\bin;.;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Program Files\Java\jdk1.6.0_39\bin;C:\app\jw\product\11.1.0\client_2\bin;C:\app\jwbaker\product\11.1.0\client_1\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\PuTTy;c:\Program Files (x86)\Common Files\Ulead Systems\MPEG;C:\Program Files (x86)\Windows Imaging\;C:\Program Files (x86)\sysinternals\;C:\Program Files (x86)\Enterprise Vault\EVClient\;C:\Windows\SUA\common\;C:\Windows\SUA\usr\lib\;C:\Program Files\TortoiseSVN\bin;
    toload is C:\Users\lba\AppData\Local\Temp\OraInstall2013-04-14_06-53-42PM\WindowsGPortQueries.dll


    ReplyDelete
    Replies
    1. First things Please do not try to install the OS remotely, secondly you will find the refhost.xml file inside the installer CD or downloaded folder for installation.

      Delete
  19. Hello Sir,
    I installed Oracle Developer 10g x32 on Win7 x64bit but when i open some Report builder it keep crash on some Jsp files, i did the compatibility issues with win xp sp2 and sp3 and i did connect to database to avoid crashing, and batch p5983622_10123_WINNT was installed and it still keep crashing with jsp files, but rdf not crashing,
    so please do u have any solution for this error... or if there is any link for 10g x64 or batch for x64
    wish to hear from u soo soon
    Best regards
    Hadi Hosnia

    ReplyDelete
    Replies
    1. Which Browser you are using. I think think your browser memory protection is enable.
      Try to disable it and restart your system.
      go to internet explorer -> Tools -> option ->Advance -> security section and disable the memory protection. Please check this link: https://forums.oracle.com/forums/thread.jspa?threadID=1030490 ‎

      Delete
    2. Sir, when i open the report in report builder not in browser it crash
      when i open it in browser it works great,

      Delete
    3. Dear,
      This is the continuous issue with the report builder. Which version report builder you are ‎having? Try to apply the latest patch. I think is better to contact with the oracle support.‎

      Delete
    4. Sir,
      I have Report Builder 10.1.2.3 with batch p5983622_10123_WINNT,
      I would like to know if install the Developer Suit 11g x64bit... might it work with the Database 10g? and will it cause any connection problems to database?

      Delete
    5. is there any new batch for the 10g ? because even 10.1.2.3 was for fixing the jsp bugs but still not working well for all files
      and thank you for your help, and for replying me Sir
      hope to hear for any news if available in future
      and if i can have ur email to contact u any time
      Regards,
      Hadi

      Delete
  20. Hi Shahid
    I have installed Oracle 10g forms on Windows 7 & created sample forms but when
    i run the form getting error with Internet explorer has stop working and could't run the form.

    ReplyDelete
    Replies
    1. Dear,

      You need to replace the jinititator which is no longer supported or compatible with newer ‎version (above version 6) of internet explorer. Go to the oracle directory to find the ‎jinititator C:\Program Files\Oracle\JInitiator ????\bin\ and replace jvm.dll with the one ‎existing in (program files\java. For better understanding either check the above similar ‎discussion or the below link for more clear understanding: Forms: How to Configure ‎Forms Builder to run forms locally.‎

      Delete
  21. salam shahid i using oracle 10g XE i want to connect it with visual studio ... ho to conect it with visual studio..

    ReplyDelete
    Replies
    1. Walekum salam,

      check this link:
      http://blogs.msdn.com/b/kaevans/archive/2009/07/18/connecting-to-oracle-from-visual-studio.aspx
      otherwise you can google some more link.
      Hope it will help you!

      Delete
    2. Dears,
      Here is a resource with more details on the Visual Basic/C# connectivity with the Oracle db
      http://www.oracle.com/technetwork/articles/dotnet/cook-dotnet-101788.html

      Sincerely,
      Mazhar

      Delete
  22. Hi Shahid

    I have installed Oracle Developer Suite 10g (10.1.2.0.2) on windows vista. when i try to open a .fmb file, i get the error "Oracle forms designer has stopped working". Please help.

    ReplyDelete
    Replies
    1. Dear,
      Check your browser and Jinitiator version. You can also get help with the above discussion of almost same type of issues.

      Delete
  23. Hi Sir ,
    I am abhisekh , i have installed developer suite on VM-Ware(VartualBox), while running from XP(Base operating system) it works fine but when i am running through Windows-8(Base OS) it throws different errors. please help me to short out this problem

    ReplyDelete
    Replies
    1. Dear,

      I have not tested on windows-8 yet but you can try the same concept above in this article. Increase the virtual memory and use the above concept. If you still face any issue then go through the different discussion just above.

      Delete
  24. Assalamu Alaikum Shahid Bhai,

    Dear,

    I am facing a problem with I/O & db file scattered read > 3

    Pl help in this regard.

    my email id is : arksadba@gmail.com

    If required i ll send the output of I/o querries

    Thanks and Alla Hafiz

    ReplyDelete
    Replies
    1. Walekum Salam Brother,
      There are different reason for I/O & db file scattered read > 3.
      Try to search the related article i already uploaded for that with the name: "Session performance issue in oracle DB"
      link: http://shahiddba.blogspot.com/2013/03/session-performance-issue-in-oracle-db.html
      and please write your comment on related article.
      Hope you will find the solution
      Thanks and best Wishes
      Shahid Ahmed

      Delete
  25. Dear Mr. Shahid, AsSalam u Alaikum,
    Thanks for the useful site and postings. I did a google search 'Oracle Developer Suite 10g Installation Error on Windows 7 Professional Checking operating system version: must be 5.0, 5.1 or 5.2 . Actual 6.1'
    and your site came up on top of the search results. This error was the first problem I encountered in my new job.
    Looking forward to more interactions ...

    Sincerely,
    Mazhar

    ReplyDelete
  26. hi..Im student from Informatics engineering, this article is very informative, thanks for sharing :)

    ReplyDelete
  27. salam shahid bhai, could you please guide me where can i dowload oracle 10g software.
    thanks
    syed

    ReplyDelete
  28. Hello sir,

    Reports 10g was working fine on my 32 bit system. But recently i have upgraded to 64 bit and then the reports 10g has stopped working. I have installed the reports correctly. When i open the reports exe it opens fine but when i try to open any existing report, Reports developer crashes. Request you to help me with this regards.

    Thanks,
    Aniket

    ReplyDelete
  29. Hi sir .....
    sir i have installed dev suite on windows 7 home premium 64 bit os it installed but the problem is that when i open a form in form builder in goes off and show error message that "check a online solution" and other one is "
    close the form builder" i tried both but not find any solution ..where a report builder is running in a proper way and sql plus is also running and connect to the database ..but form builder has problem when open a .fmb file.. Please help me sir..
    Thanks and regards in advance..

    ReplyDelete
    Replies
    1. Dear Amit,
      Check your browser setting (Open browser setting – option- advance tab and Uncheck “Enable ‎memory protection) but as you mention your report builder is working properly it seems the ‎browser is correct. Try to increase virtual memory and restart your system. Also note the ‎following things:‎
      Check you are opening the correct version source file (like old form new OS) and ‎sometimes you are trying to open the module which already depending on another ‎module.
      Do not forget to read the above discussion may it help you.

      Delete
  30. Thanks !!.. It helped me alot

    ReplyDelete
  31. thanks, this article helped me in installing on the host machine. I was using a windows xp mode before to open reports with Reports 10g

    ReplyDelete
  32. hii shahid,
    i have installed oracle development suite 10g on windows 7(64-bit) laptop but its not asking me for password management during installation and unable to connect database because of it. kindly help me plzz

    ReplyDelete
    Replies
    1. Dear,

      Oracle Developer suite does not have Username/password. I think it is asking for Oracle 10g database already you have installed on your system. Try to use Oracle 10g Database default password for the user 'SYS' and password is 'CHANGE_ON_INSTALL'

      Delete
  33. Salam Alykom Shahid,

    Thanks for the interesting article, we have installed developer suite version 10.1.2.0.2 and would like to install the 10.1.2.3 in our PCs(xp+xin7)
    1. what is the recommended patch number to upgrade? and is there a separate installation dvd for version 10.1.2.3?
    2. what would you think better use Jinitiater or JRE ? and what the compatable version of both of them to 10.1.2.3?

    Many Thanks
    Bilal

    ReplyDelete
    Replies
    1. Dear Bilal,

      For upgrade check the patch set ML Patch#5983622. Try to read associated ‘Readme’ before ‎applying the patch. Also check the Metalink Note: 329361.1, Metalink Note: 555681.1‎
      For more details.‎
      In fact Jinitiator is very old java based which is not supported directly on some of the ‎latest operating system. Jinitiator support IE6. Higher of IE6 not supported by Jinitiator, ‎for that you need to configure or use JRE.‎
      If you are going to upgrade your version 10.1.2.3 then I will suggest you must use JRE.‎

      Thanks
      Shahid Ahmed

      Delete
  34. Path Infotech is in the field of oracle training program from past several years.

    For more info : Oracle 10g Certification

    ReplyDelete
    Replies
    1. Please don't paste any advertisement link with this site.

      Delete
  35. "Assalam Alikum" i sayeed akhat i have installed oracle 10g enter prise edition fro create database on windows 7(32/64-bit) both but its getting error Psapi.dll file could not locate din the system
    i have all ready try for given information in your blogs i have fetching same error earlier and now pleace help me

    ReplyDelete
  36. hi, Nice post buddy. I installed perfectly on windows 7. but reports are not being launched from oracle forms. it gives me
    REP-52251: Cannot get output of job ID
    I tried Single sing on, and other ways too. but I couldn't fix this bug. please suggest me anything.
    thanks.

    ReplyDelete
  37. Dear Usman,

    - Set the REPORTS_PATH environment variable defined in $ORACLE_HOME/bin/reports.sh
    - or Check the registry (REGEDIT) for library path set the exact REPORT_PATH environment variable.
    Check the library is present in the same directory as the reports.
    - Sometimes due to re-installation some garbage set as a path which length more
    that expected character, so check report length path not more than 1024.

    ReplyDelete
    Replies
    1. Thanks for your reply Sir. actually this is for the first time I am playing with reports configuration.
      I am using database 11g and forms&reports 10g. as you said $ORACLE_HOME$/bin/reports.sh , i couldn't find it in any directory. and changed the regedit REPORTS_PATH , still not working.
      and please can you explain little more what about "Check the library is present in the same directory as the reports." ?
      thanks

      Delete
  38. I have a problem connecting to any Oracle database from the 10g R1 tools on a Win 7 machine. I always get an ORA-02248: invalid option for ALTER SESSION error when attempting to connect (from within the Form Builder or even using SQL*Plus). We gave up on this long ago and just decided to run it on XP, but that is becoming less of an option. Any idea what might be causing this? I think it might be some sort of registry setting that is not right on the Win7 machine, but I'm not sure where to start.

    ReplyDelete
  39. I have installed successfully oracle developer suite 10g on windows 7 os. Can you suggest how to make it web enabled. I have an internet connection but I do not have any website or url. How can I access the form from another place. I mean there is no LAN.

    ReplyDelete
  40. thank you ahmah shaid, I have the same problem with oracle 10g , when I download oracle 10g the same message it coming,
    what I can do please> thank you very much

    ReplyDelete
  41. HI, I tried to install Oracle Developer Suite 10G on windows 7 ultimate (64 bit) under the above mentioned instructions and got it installed successfully. However, I am having few problems:

    - I am unable to find E:\Installers\Oracle_10g_1023\Disk1\stage\prereq\db or refhost.xml anywhere in my installation CD (Oracle Developer Suite 10G) which contains two folders [Oracle Developer Suite 10g (disk1) and Oracle Developer Suite 10g (disk2)]
    - When i tried to connect SQL*Plus, it gave me ORA-12560: TNS PROTOCOL ADAPTER ERROR
    - I am unable to see any Oracle service under Windows Services

    Where should I look for these issues?

    ReplyDelete
  42. Thanks for Information Oracle 10g/11g Database Administration In this course, you will explore how an Oracle Database applies ‘grid computing’ to multiple computers to provide fast, efficient, secure data storage and manipulation that easily scales to thousands of clients. You will learn how to install, administer, and maintain an Oracle 10g or 11g database in an effective and efficient manner. You will cover the interaction among Oracle components, Oracle’s architecture, and user management. Performance monitoring, database security, and backup and recovery techniques are covered. This course will assist those preparing to take the Oracle Certified Associate (OCA) certification examination.Oracle 10g / 11g DBA Online Training

    ReplyDelete